
Computer Graphics & Animation: CS Day @ SIUC
This session explores computer graphics and animation using software that will let you create, display and 
animate 3D Objects. Basically we will create a 3 dimensional description of an object in the computer 
(modeling) and then simulate what it would look like based upon shining light on it and creating an image 
using a synthetic camera(rendering). An animation will show the object moving in time.

Objects can be defined within the computer by specifying their geometry and surface properties. To make it 
easier to define objects, applications (created by Computer Scientists              ) are commonly used. We'll be 
using the program Art of Illusion (free download at http://www.artofillusion.org/) for this purpose.
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AOI Tool Palette

AOI main Window

1. Open Art of Illusion
a. Notice the view windows and tool 

palette. View windows show the 
world from different views. Grids 
can be turned on/off through the 
Scene -> Grid ... menu. The Grid 
snap feature makes it easier to 
place items at precise locations,

b. Tools let you create and manip-
ulate objects. They are shown in 
the color coded guide on the right.

BLUE: creates objects
GREEN: manipulates objects
BROWN: manipulates the view

www.cs.siu.edu/~wainer/AOIpractice/CSDAYwithAOI.htmlSession website:

http://www.artofillusion.org/
http://www.cs.siu.edu/~wainer/AOIpractice/CSDAYwithAOI.html


Building a Rocket
As an example of a model, we'll show how to build a rocket and then animate it. Follow through the basic 
sequences first, then you'll also be able to try your own variations.
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2. Getting Ready to Work: setting grid & coordinate range
a. The Scene Menu has a Grid option to show the grid and turn snapping on.
b. The magnification number can be lowered to show more of the scene.
These modifications apply to the current view window.

c. Use the “Move Viewer” 
tool to show more of a 
positive y range in the Front 
view window.

3. Making the Rocket Body

4. Adding some Color
Object colors are determined by their surface properties (texture, 
material) and how light bouncing off of them is reflected to the 
viewer. With your cylinder still selected:
a. Use the  Object Menu, Set Texture, option. Using a Simple 

Texture type, click New Texture. 
b. Name your new uniform texture – which will basically be a 

color. Let's try “Burgundy”. Type in the name and click OK.

c. To define your color,  click the Diffuse 
Color box – another popup will let you 
adjust the color to your liking. Once you're 
happy, click OK.

d. You might also like to give your texture 
some “Shininess”.

e. Keep clicking OK until all the extra dialogs 
are dismissed. Your object should appear 
with the new color.

Notice: that different color models can be used

a. Use the  “Cylinder” tool to create a cylinder in the Front view window.
    Make the cylinder bottom at y=0, with a height of 2 and width of 1
    centered about x =0.
b. Use the “Move” and “Resize” tools if needed. Delete extra objects or
    start over again if needed.
Notice how the same cylinder also appears in the other view windows.



Building a Rocket, continued.
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5. Adding Stage 2
a. Create another cylinder of height 1 in y to be the second stage.
b. Set it on top of the first stage. No need to change the color just yet.
c. Find the Cylinders you created in the Object List (on the right). Rename 

the objects to Stage1 and Stage2. You may also adjust the position and 
size of the cylinders. Properties will be different depending upon the type 
of object selected.

d. Select the “Rotate Viewer”           tool and move to the Camera 1 view. 
Adjust the view angle a bit to get a better look at your objects.

6. Add a Nosecone

7. Group all the Parts into a Rocket Object

a. Select Stage2 and Copy/Paste it to make a duplicate. Look in 
Edit Menu or use Control-C for copy and Control-V for paste. 

b. The duplicate will be right on top of the original. In the Front 
view, use the “Object Move” tool to drag it up 1 unit in y.

c. Using the Properties, change the name to Nosecone and 
convert it to a cone by changing the “Ratio Top/Bottom Radii” 
to 0.

a. Use the Object Menu, Create Primitive option 
to create a “Null” object. This works  like a 
folder to group other parts together.

b. In Properties, change its name to Rocket.
c. In the Objects List, drag the names of other 

objects to be inside of Rocket.

Your object list should look like that on the right.

Set to zero to 
make a cone

Objects are selected using the
“Object Move”        tool or by
clicking on the object in the
Object List.

Selecting Objects

Save



Building a Rocket, creating a tailfin
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8. Making a Single Tailfin
a. Double-click the “Create Polygon” Tool. 
    Set it to create 5 sided angled polygons.
b. Hold the control key down, and use the “Create Polygon” 

Tool to create a polygon roughly 2x2 in size. You won't be 
making the exact shape just yet.

c. Change to the “Move Object” Tool to select and double-click 
on your new polygon to open the mesh editor as shown 
below.

d. With the “Move Point” Tool, adjust the shape of the Triangle 
Mesh (Polygon) within the Front view to make a good tailfin. 
Click-OK when you have a shape similar to that shown.

9. Place the Fin and Give it Thickness
a. In the “Front View” drag the fin into position at the bottom right 

side of the rocket. Notice how the fin appears only as a line in the 
“Top View”. It has no thickness!

Tailfin shape created 
by moving polygon 
points.

b. With the fin selected, open the 
Tools Menu pick Scripts and 
choose “Thicken” . Enter a 
thickness of 0.1 and click OK.

c. You should see your fin thickened 
but it is no longer evenly centered 
about the Z=0. Use the Object 
Menu and select “Align 
Objects ...”. Only Center align Z 
values to the number 0.

When first created, the tailfin has 
no thickness.



Building a Rocket, creating a set of tailfins
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10. Rename and Color the Tailfin
a. Rename your object to “Fin”. (Recall Step 5c.)
b. Create a new “Yellow” texture for “Fin”. 

(Recall Step 4). Hint: High Red and Green 
values make Yellow in the RGB Color system.

You should have something like that on the right

11. Making More Fins
a. Select the Rocket and all its parts in the Object List. Use the Object Menu, “Hide Selection” to temporarily 

make the Rocket body invisible.
b. Position the Rocket fin so its left side lines up against the y-axis. Make the bottom left side lie at the origin. 

Make sure the rocket fin is still selected.
c. Use the menu, Tools, Edit Script ... . A text window appears for a script to be entered. Copy/Paste the script 

Tailfins.bsh (URL: http://www.cs.siu.edu/~wainer/AOIpractice/TailFins.bsh )
d. Execute the script. It will ask you for the number of Rocket Fins and Radius of Rocket. Enter 3 and 0.5 

respectively. After the script finishes, 3 new rocket fins will appear.
e. Hide the original Rocket Fin (as in step 11a above).
f. Make a new Null object; name it “Rocket Fins” and place all 3 new fins within it. (Recall step 7).
g. Unhide the Rocket (select in Object list and use the Object Menu, “Show Selection” command) and group 

Rocket Fins within the Rocket object.

Software can often automate repetitive , tedious 
and/or complex tasks to remove the burden from 
users.  

Scripts

Save

http://www.cs.siu.edu/~wainer/AOIpractice/TailFins.bsh


Flying the Rocket

SIUC CS Day: Computer Graphics & Animation page 6

12. Create a Flight Path
A sequence of images is created to show how a scene varies in time. When 
played back at an appropriate speed, the effect of motion is created.  

Animation 

To make the rocket fly, we'll create a flight path using a curve, and then tell the rocket to follow that path.
a. Adjust the Front View and Left View magnification to view more of the scene (use a number close to 10)
b. In the Front View use the Interpolate Curve Tool to create a curve that starts on the ground and arcs up 

into the sky.

Curve 
Editor

c. Edit the Curve 
Object (Object 
Menu, Edit Object) 
to adjust the points 
with more control. 
Click OK when 
finished. A more 
detailed curve 
editor window will 
pop-up. See below.

Adjust the magnification 
and grid settings in these 
windows as needed. 
Once back in the regular 
scene editor, you can 
drag and resize the flight 
curve.

Feel free to delete a 
curve if it becomes hard 
to deal with – you can 
make a new one and try 
again.

d. Use Properties to rename the curve you just created to “FlightPath”.1 More
Thing!



Flying the Rocket, continued
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13. Attach the Rocket to its Flight Path

a. Select both the FlightPath Curve and Rocket Objects. 
(Select the first object and then hold the Shift key down 
while clicking on the second object )

b. In the Animation Menu, select, Set Path From Curve ... A 
dialog box will pop-up. Make sure the “Orientation 
Follows Curve” under Constant Acceleration  is clicked 
and that Start Time and End time go from 0 to 4. The other 
values will be generated for you. Click OK.

c. Select the objects within “Rocket” and in the Animation 
Menu, choose the “Bind to Parent Skeleton ...” option. 
This makes sure the rocket parts follow the rocket 
grouping along the curve.

A Confirmation box will appear. Click OK.
You'll see new animation tracks appear along the bottom
in the animation view.

14. Seeing it Move
a. In the Animation Menu, select, Preview Animation... A 

dialog box will pop-up. Make sure the settings are as 
shown then Click OK.

b. A preview of the Rocket Motion will be generated. If you 
need to change things you'll have to go back and modify 
your work – change the FlightPath etc.

Close the Preview when you've 
finished viewing it.

Select in List

Select in 
Diagram



Turning the Animation into a Movie
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15. Generating the Frames
a. Select from the Scene Menu, Render Scene... This will 

open a dialog box. Make sure all the fields are filled in 
as they are shown to the right. This determines the size 
of images for the movie, the range of simulated time 
that should be generated and the playback speed.

b. Click the Output ... options button and make sure that 
images with a transparent background are generated.

c. Click OK to close the Output and Rendering Option 
boxes.

d. Next another dialog will appear asking for the format 
(Pick PNG) and the starting number for the frames. 
Pick 1. Click OK.

e. Next you will get a chance to pick the root name of 
your image sequence (60 files) and where to store it. 
Please make a folder under My Documents such as 
csDay. Within that folder give a name like 
“launch.png”. Click OK. The images will be generated 
and saved automatically – it might take a little while.

16. Stitching Frames into a Movie

a. Start the Quicktime Player (Pro) application.
b. From the File menu, select Open Image Sequence. Go 

to the folder where you saved the frames that AOI 
generated and pick the one with the lowest number.

c. When asked for the frame rate, pick 15. Hit OK.
d. The frames are stitched together to make a movie. You 

can play it play clicking on the Play button.

The background is shown as black 
but it is also transparent!



Turning the Animation into a Movie
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a. From the Quicktime File menu, Open the background 
image “launchBg.png” available from the web. 
Another Quicktime player window opens.

b. In the Edit Menu, Choose Select All and then Copy.
c. Back in the Quicktime Player showing your Rocket 

movie, use the Edit Menu, Select All option also (but 
DON'T copy)

d. Position the time index to 0
e. Use the Edit Menu, Add to Selection and Scale option

17. Compositing with a Background

18. Adjusting the Tracks

Your movie now has 2 tracks. Track 1 has the 
rocket frames and track 2 has the still 
background image. But it has to be moved 
behind the rocket images.
a. Open the Quicktime Window Menu, 

“Show Movie Properties ...” and Select 
Visual Settings as shown

b. Select (highlight) Video Track 2 and 
adjust the Layer Number to be 2. This 
will move it behind the rocket frames.
c. To make the rocket frames transparent, 
select Video Track 1 and adjust the 
Transparency to Straight Alpha.

You should see a result similar 
to that at the top.

Try playing your movie now!

Many special effects combine 
computer generated images 
with real ones.

http://www.cs.siu.edu/~wainer/AOIpractice/launchBg.png


19. Save Your Movie by Exporting From Quicktime

23. Add Other Objects to the Scene

Some Other Things to Try

21. Making Your Rocket Explode
Animation Menu, Add Track to Selected Items, Distortion, Shatter

22. Add More Details
Add additional geometry to your rocket – try an exhaust port made by subtracting a 
smaller cone (or sphere) from a larger one. Tools menu, Boolean Modeling

24. Try Making a Procedural Texture

25. Experiment with Rendering

20. Add More Scenes to Your Movie
Create a new flight path and use a different background image. Add to previous movie.

For starters, just try Scene Menu, Display Mode

Check out the Art of Illusion Gallery

Thanks for joining us for CS Day at SIUC. We hope you enjoyed it . 
- Dr. Michael Wainer      http://www.cs.siu.edu/
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http://www.artofillusion.org/artgallery
http://www.cs.siu.edu/

